Sunday, November 04, 2007

DILE v0.2.6: VC++ SP1 runtime

A few days ago I tried to run DILE on a Windows XP machine which had only .NET Framework installed. Of course, I got the usual System.IO.FileLoadException. So, I installed the VC++ runtime which is needed because the Dile.Debug.dll is actually a mixed assembly. However, this didn't solve the problem. After searching a little bit on google I noticed that there is a new VC++ runtime which was published together with the Visual Studio SP1. Since I am using Vista, I also installed the SP1 and as a result the Dile.Debug.dll references the new SP1 runtime.

So, please install the VC++ SP1 runtime if you want to use DILE v0.2.6 on a machine which doesn't have Visual Studio SP1 and/or the VC++ components installed.

I have updated the .zip files on Sourceforge (I only changed the readme.txt, nothing else) and fixed the readme.txt to contain the correct links.
So, here is the updated readme.txt file separately, plus the links to the correct runtimes:
x86 VC++ SP1 runtime
x64 VC++ SP1 runtime

Of course, if you have already downloaded DILE v0.2.6, then it is not necessary to download it again, just remember to use the new runtime if you ever receive a FileLoadException.

Labels:

2 Comments:

Anonymous Anonymous said...

Hi,
Are still devloping DILE or is the project dead?
ks

Thursday, October 30, 2008 at 2:58:00 PM GMT+1  
Blogger Zsozso said...

Hi,

That's a very good question. I wouldn't consider it dead. No doubt, I haven't spent too much time on it lately but if you find a bug or you want a new feature to be added then I will try to solve it ASAP.

And I still plan to finish DILE, which means that I want to complete the last part: editing and compiling assemblies.

So, no, I wouldn't consider it dead. :-)

Regards,
Zsolt Petreny

Friday, October 31, 2008 at 12:48:00 AM GMT+1  

Post a Comment

<< Home